Arquivo da tag: ati

Flick com XGL e Beryl

ATENÇÃO: Este conteúdo foi publicado há 10 anos. Eu talvez nem concorde mais com ele. Se é um post sobre tecnologia, talvez não faça mais sentido. Mantenho neste blog o que escrevo desde os 14 anos por motivos históricos. Leia levando isso em conta.

Não sabe o que é o Flick? É o meu Acer Aspire 5050-3205. Não sabe o que é XGL e Beryl? Google it! ;)

Por sugestão do Schneider, instalei Xgl e Beryl no laptop. Demorou um pouco e tive alguns problemas emergindo tudo, mas agora estou sob KDE+Beryl+Aquamarine com a minha ATI Radeon Xpress 1100.

Constatações pra quem nunca viu isso: É bonito. Existem muitos mais recursos do que aqueles mostrados nos vídeos da internet e é difícil usar todos. O computador fica um mais devagar, mas a diferença é pouca. Você impressiona qualquer usuário Windows sem dificuldade. É complicado instalar, configurar e usar. E agora eu ainda tenho que encontrar coisas bonitas pra combinar com os efeitos loucos 3D dele.

Queria gravar um videozinho também como todos esses caras na internet fazem, mas eu acho que o VNC deixaria tudo muito lerdo. Como que os caras gravam? Usando uma câmera de verdade? Alguma sugestão?

Widescreen 1280×800

ATENÇÃO: Este conteúdo foi publicado há 10 anos. Eu talvez nem concorde mais com ele. Se é um post sobre tecnologia, talvez não faça mais sentido. Mantenho neste blog o que escrevo desde os 14 anos por motivos históricos. Leia levando isso em conta.

Minha lógica estava correta. Estou agora a 1280×800 aqui no Gentoo, com KDE, um wallpaper lindo nessa tela CrystalBrite e continuando para os meus próximos itens da ToDO list que fará meu laptop funcionar:

  • Som – ALSA, HDAUDIO, fica dando um monte de mensagens no boot e não funciona.
  • DVD/CD – Não sei direito como eu devo fazer, vou dar uma olhada lá na parte de CD do Kernel. O CD do meu velho ze4610us já era chatinho de configurar…
  • USB – tá funcionando, só que ele não tem sda, e não tô conseguindo fazer aquelas mágicas do udev.
  • AltGr+W = ? – Xmodmap ou algo do gênero… ainda não sei como se faz. Se alguém quiser me ajudar, sinta-se a vontade. ;)
  • Webcam – Vou começar pelo Google.
  • Wireless – Vou começar pelo Google.

Hoje é o dia!

ATENÇÃO: Este conteúdo foi publicado há 10 anos. Eu talvez nem concorde mais com ele. Se é um post sobre tecnologia, talvez não faça mais sentido. Mantenho neste blog o que escrevo desde os 14 anos por motivos históricos. Leia levando isso em conta.

Hoje a noite eu espero poder postar um artigo feliz aqui dizendo que estou no meu laptop a 1280×780! Depois de varrer a internet e de dias tentando, acho que encontrei a solução para o fglrx funcionar com a ATI Radeon Xpress 1100 do meu Acer Aspire 5050-3205.

A solução baseou-se, entre outros sites, em dois casos de caras com Ubuntu que tiveram problemas semelhantes: esse e esse. Depois de um tempão tentando fazer outras coisas, parece que o problema que estava me impedindo de tudo funcionar corretamente era a versão do Xorg (!). Estou com o xorg.conf do Elvish Legion, do primeiro fórum, e agora emergindo o meu Xorg para a 7.1 como fez o Berin do segundo!

O problema que eu estou tendo é exatamente igual o dele:

(WW) ****INVALID IO ALLOCATION**** b: 0x9000 e: 0x90ff correcting
(...)
Requesting insufficient memory window!: start: 0x9000 end: 0x90ff size 0xc0120100
Requesting insufficient memory window!: start: 0x9400 end: 0x94ff size 0xc0120100
Requesting insufficient memory window!: start: 0x9800 end: 0x98ff size 0xc0120100
Requesting insufficient memory window!: start: 0x9c00 end: 0x9cff size 0xc0120100
(EE) Cannot find a replacement memory range
(...)
(EE) fglrx(0): RegisterResources failed
SetVBEMode failed
(EE) fglrx(0): PreInit failed

Em breve novidades… ;-)

Posts relacionados

Quando eu tiver um Linux totalmente configurado pro Acer Aspire 5050-3205, eu vou encher uma página de informações sobre como configurá-lo pras próximas vítimas serem mais felizes na estréia do laptop novo…

Ahhhh! Esse laptop está me rendendo um monte de paraquedistas! Parece um modelo novo que todo mundo tem pesquisado… e meu site tá bem localizado lá no Google, tanto que eu sou o primeiro resultado em várias buscas de pessoas procurando por como fazer a ATI Radeon Xpress 1100 funcionar!

Olha… Se você chegou aqui procurando por esse laptop e sua compatibilidade com Linux, além de ler os posts relacionados, saiba que ele é difícil de ser configurado, mas que na teoria tudo vai funcionar!

emerge happiness

ATENÇÃO: Este conteúdo foi publicado há 10 anos. Eu talvez nem concorde mais com ele. Se é um post sobre tecnologia, talvez não faça mais sentido. Mantenho neste blog o que escrevo desde os 14 anos por motivos históricos. Leia levando isso em conta.

Gentoo tem se mostrado uma ótima distribuição. Não sei por quê, eu achava que ele era difícil, mas não… Talvez a instalação a partir da minimal seja, mas do jeito que eu estou fazendo está tudo bem, com exceção da dor de cabeça pra configurar os drivers aqui no meu Acer Aspire 5050-3205.

Instalar os drivers proprietários da ATI foi muito fácil:

# emerge ati-drivers

Baixou, instalou, eu rodei o aticonfig e ele já alterou o /etc/X11/xorg.conf pra mim. O problema é que esse driver não roda a minha ATI Radeon Xpress 1100. Trecho do log do Xorg:

(II) Primary Device is: PCI 01:05:0
(II) ATI Proprietary Linux Driver Version Identifier:8.32.5
(II) ATI Proprietary Linux Driver Release Identifier: LGDr8.32g1
(II) ATI Proprietary Linux Driver Build Date: Dec 12 2006 17:18:49
(II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.32.2.1.2.3-driver-lnx-x86-x86_64-313294
(--) Assigning device section with no busID to primary device
(--) Chipset ATI Radeon Xpress Series (RS482 5975 Generic 5975) found
(II) resource ranges after xf86ClaimFixedResources() call:
...
(II) Setting vga for screen 0.
(II) fglrx(0): === [atiddxPreInit] === begin, [x]
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/lib64/xorg/modules/libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 0.1.0
        ABI class: X.Org Video Driver, version 0.8
(II) fglrx(0): PCI bus 1 card 5 func 0
(EE) fglrx(0): RegisterResources failed
SetVBEMode failed
(EE) fglrx(0): PreInit failed
(II) fglrx(0): === [atiddxPreInit] === end
(II) UnloadModule: "fglrx"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/lib64/xorg/modules/libvgahw.so
(EE) Screen(s) found, but none have a usable configuration.
.
Fatal server error:
no screens found

Agora o alsa não tá funcionando, não sei por quê. Já recompilei o Kernel umas 20 vezes… mas isso tudo bem. O problema é a placa de vídeo mesmo… Ninguém tem essa placa pra me ajudar?

Concluindo, falta uma coisa na portage do Gentoo para quem usa placas de vídeo da ATI e tela com widescreen:

# emerge paracetamol

Dor de cabeça

ATENÇÃO: Este conteúdo foi publicado há 10 anos. Eu talvez nem concorde mais com ele. Se é um post sobre tecnologia, talvez não faça mais sentido. Mantenho neste blog o que escrevo desde os 14 anos por motivos históricos. Leia levando isso em conta.

Anteontem formatei o laptop e instalei o slamd64. Por ordem de prioridade, lá vão os problemas…

Problema 1: placa ATI Radeon Xpress 1100. O “ati” do Xorg não suporta. Eu não consigo instalar os drivers proprietários. Baixei lá do site da ATI e rodei normalmente o arquivo e ele não abre o instalador gráfico que deveria abrir:

root@laptop:~# ./ati-driver-installer-8.32.5-x86.x86_64.run 
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.32.5........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 6.9.x 64-bit
Removing temporary directory: fglrx-install
root@laptop:~#

(e, sim, não estou em root por su, o que poderia fazer eu não ter um DISPLAY, mas entrei no X como root mesmo)

Essa série 1100 parece ser nova porque há pouca informação sobre ela na internet. Alguém sabe ajudar?

Sem configurar a placa, não consegui usar 1280×800, aí tudo está “gordo” e desfigurado, porque estou usando 1024×768 num monitor widescreen (driver vesa).

Problema 2: 64 bits. Firefox com Flash, codecs proprietários do mplayer, Java. Achei que fosse mais fácil… O hlegius fez um comentário bem pessimista lá no outro post… E ele tem razão. Estou com o live-cd do Gentoo amd64 baixado esperando um CD virgem pra gravar (devo comprar hoje a tarde), todo mundo fala bem do Gentoo pra 64bits. Ainda tô baixando também o Ubuntu pra 64bits pra ver como é que é…

Eu não sei como se faz pra emular um subsistema de 32bits pra rodar Flash por exemplo. Depois também vou precisar de ajuda… mas a prioridade agora é o monitor mesmo.

Problema 3: Resto do hardware. Gravador de DVD, webcam, wireless. Nunca useu nenhum dos três. Vai ser uma experiência nova super divertida, com mais dor de cabeça ainda.

Problema 4: Teclado. Depois tenho que dar uma olhada no Xmodmap (acho que é isso que eu tenho que usar) pra fazer o ponto de interrogação (Altgr+W) funcionar.

Problema 5: O som hdaudio funciona, mas dá um monte de erro quando o udev detecta e inicia o alsa. Depois tenho que verificar…

Conclusão: Pelo visto esse mês (no mínimo) vai ser só dor de cabeça. Mas o aprendizado com certeza vai ser grande. ;) Quem já tiver passado por esses problemas e quiser me ajudar nessa aventura será muito bem recompensado (por Deus ou algum cara assim que você acreditar, porque meu dinheiro acabou na compra desse laptop… hehehe).